Retrieves the element sets that contain a given element.
GSErrCode ACAPI_ElementSet_Identify ( API_Guid elemGuid, GS::Array<API_Guid>* setGuids );
Parameters
- elemGuid
- [in] The element GUID to search for, or
GS::NULLGuid
to get all element sets. - setGuids
- [out] Array of GUIDs of the element sets that contain the element.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
setGuids
parameter isnullptr
. APIERR_BADDATABASE
- The function cannot operate on the current database.
For other common API errors see the API Errors document.
Remarks
You can use this function to identify the element sets that refer to the passed element.
Note that element sets created by other add-ons will not be examined. You can get all element sets created by your add-on if you pass GS::NULLGuid
in the guid
parameter.
For a utilization sample of this function see the Example section of ACAPI_ElementSet_Delete.
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_ElementSet_Create
ACAPI_ElementSet_Delete
ACAPI_ElementSet_GetData
Element Set Manager
API Functions