ACAPI_​Environment

Controls the environmental data of the server application.

    GSErrCode  ACAPI_Environment (
        API_EnvironmentID     code,
        void*                 par1 = nullptr,
        void*                 par2 = nullptr,
        void*                 par3 = nullptr
    );

 

Parameters

code
[in] Environment function identifier.
par1
[in/out] The parameter depends on the code parameter.
par2
[in/out] The parameter depends on the code parameter.
par3
[in/out] The parameter depends on the code parameter.

 

Return Values

NoError
The environment function completed with success.
APIERR_BADID
Invalid code parameter was passed.

More return values can be found at the description of each environment function.

 

Remarks

This function is used to access the environmental information of the server application.

The type of the environment function is specified with the code parameter.

API_EnvironmentID

Description

 

 

General environment

 

APIEnv_ApplicationID

Returns information about the current application.

APIEnv_ProjectID

Returns information about the current project file.

APIEnv_ProjectSharingID

Returns the project sharing data in the case of a TeamWork project.

APIEnv_GetProjectNotesID

Returns information about the ‘Project Info’ dialog.

APIEnv_ChangeProjectNotesID

Changes the data of the ‘Project Info’ dialog.

 

 

Active libraries

 

APIEnv_GetLibrariesID

Returns the list of loaded libraries.

APIEnv_SetLibrariesID

Changes the list of loaded libraries.

APIEnv_ResetLibrariesID

Resets the loaded libraries.

APIEnv_NewLibDialID

Instructs the user to select a new library folder in a dialog.

APIEnv_AddLibrariesID

Registers a new folder into the list of active libraries.

APIEnv_CheckLibrariesID

Checks the currently loaded libraries.

APIEnv_OverwriteLibPartID

Sets the overwrite mode for the library part create function.

APIEnv_CreateFolderInLibraryID  API 20

Creates a new folder inside a loaded library.

APIEnv_CopyFilesIntoLibraryID  API 20

Copies files into a folder inside a loaded library.

 

 

Active Settings

 

APIEnv_GetToolBoxModeID

Gets the actual toolbox mode.

APIEnv_SetToolBoxModeID

Sets the actual toolbox mode.

APIEnv_GetToolBoxInfoID

Returns information on the toolbox.

APIEnv_IsAutoGroupOnID

Returns the current state of the autogroup mode.

APIEnv_IsSuspendGroupOnID

Returns the current state of the Suspend Groups mode.

APIEnv_GetViewOptionsID  Featuring API 10

Returns the actual display & output options.

APIEnv_ChangeViewOptionsID  Featuring API 10

Changes the actual display & output options.

APIEnv_GetStorySettingsID

Returns the data of the installed stories.

APIEnv_ChangeStorySettingsID

Modifies the story structure.

APIEnv_GetGhostStorySettingsID  Featuring API 10

Returns the current ghost story settings.

APIEnv_GetPreferencesID

Returns the preferences data.

APIEnv_GetConvertedUnitValueID

Returns the preferences data.

APIEnv_GetSunSetsID

Returns information on sun parameters.

APIEnv_GetPlaceSetsID

Returns information on location parameters.

APIEnv_ChangePlaceSetsID

Changes the place settings.

APIEnv_CanChangePlaceSetsID  Featuring API 20

May the current user change the place settings now?

APIEnv_GetGeoLocationID  API 25 feature

Returns the Location data stored for the project.

APIEnv_SetGeoLocationID  API 25 feature

Sets the Location data of the project.

APIEnv_GetSurveyPointTransformationID  API 25 feature

Returns the transformation matrix that transforms points given in the Project Origin’s coordinate system into the Survey Point’s coordinate system.

APIEnv_IsSurveyPointVisibleID  API 25 feature

Checks the visibility of the Survey Point.

APIEnv_SetSurveyPointVisibilityID  API 25 feature

Sets the visibility of the Survey Point.

APIEnv_IsSurveyPointLockedID  API 25 feature

Returns the lock state of the Survey Point.

APIEnv_SetSurveyPointLockedID  API 25 feature

Locks or Unlocks the Survey Point.

APIEnv_GetExportToleranceID

Returns arc difference in output.

APIEnv_GetMagicWandSetsID

Returns information on curve tracing parameters.

APIEnv_Get3DProjectionSetsID

Returns information on the 3D projection settings.

APIEnv_Change3DProjectionSetsID

Changes the 3D projection settings.

APIEnv_GetRenderingSetsID

Returns information on the photorendering settings.

APIEnv_ChangeRenderingSetsID

Changes the photorendering settings.

APIEnv_GetRenderingSceneNamesID Featuring API 18

Gets the names of all named Rendering Scenes.

APIEnv_SetCurrentRenderingSceneID Featuring API 18

Sets the current Rendering Scene to the given named Scene.

APIEnv_Get3DImageSetsID

Returns the 3D image item settings.

APIEnv_Change3DImageSetsID

Changes the 3D image item settings.

APIEnv_Get3DWindowSetsID

Retrieves the 3D window settings.

APIEnv_Change3DWindowSetsID

Changes the 3D window settings.

APIEnv_Get3DCuttingPlanesID

Retrieves the 3D cutting planes settings.

APIEnv_Change3DCuttingPlanesID

Changes the 3D cutting planes.

APIEnv_GetCurrLayerCombID  5.2

Retrieves the index of the current layer combination.

APIEnv_ChangeCurrLayerCombID  5.2

Activates a layer combination.

APIEnv_GetCurrPenSetID

Retrieves the index of the current pen set.

APIEnv_GetNumberingGridLinesID  6.1

Retrieves the lines of the grid-based drawing numbering system.

APIEnv_IsAutoIntersectOnID  Featuring API 10

Returns the state of the automatic intersection flag.

APIEnv_ChangeAutoIntersectID  Featuring API 10

Changes the automatic intersection flag.

APIEnv_IsMarkerDrawingEnabledID  Featuring API 10

Checks whether attached objects are processed and returned during primitive decomposition.

APIEnv_ChangeMarkerDrawingEnabledID  Featuring API 10

Sets whether attached objects should be processed and returned during primitive decomposition.

 

 

System Environment

 

APIEnv_GetShowHideStateID

Gets visibility of application.

APIEnv_ChangeShowHideStateID

Changes visibility of application.

APIEnv_GetMiscAppInfoID

Gets miscellaneous information about application.

APIEnv_GetMiscPrinterInfoID

Gets general information about the current printer.

APIEnv_GetMiscPlotterInfoID

Gets general information about the plotter.

APIEnv_GetPrinterParsID  Featuring API 10

Gets various printer settings.

APIEnv_GetSpecFolderID 4.1

Returns the location of special application folders.

 

 

Archicad Layout Info  5.1

 

APIEnv_CreateLayoutID  API 24

Creates a new layout.

APIEnv_GetLayoutSetsID

Returns the current layout properties.

APIEnv_ChangeLayoutSetsID

Changes the current layout properties.

 

 

3D Document and partial structure display options  Featuring API 12

 

APIEnv_GetDocumentFrom3DDefaultsID

Returns the 3D document setting default values.

APIEnv_ChangeDocumentFrom3DDefaultsID

Changes the 3D document setting default values.

APIEnv_GetDocumentFrom3DSettingsID

Returns the 3D document settings of the specified database.

APIEnv_ChangeDocumentFrom3DSettingsID

Changes the 3D document settings of the specified database.

APIEnv_GetStructureDisplayID

Changes the partial structure display options for the current database.

APIEnv_ChangeStructureDisplayID

Changes the partial structure display options for the current database.

 

 

Library Parts

 

APIEnv_GetLibPartRefGuidID

Returns the reference guid of the given library part.

APIEnv_GetLibPartUnIDStrID  API 15

Returns the unique ID of the library part as string.

APIEnv_GetLibPartLockStatusID  API 15

Returns the current lock status of the given library part.

APIEnv_DeleteEmbeddedLibItemID  API 21

Deletes the given embedded library item (folder or library part).

 

 

Miscellaneous

 

APIEnv_CreateCopyOfGdlUserGlobalsHandleID  Featuring API 19

Returns a copy of the current GDL globals (APIEnv_GetGdlUserGlobalsHandleID was removed).

APIEnv_DestroyCopyOfGdlUserGlobalsHandleID  Featuring API 19

Destroys the previously copied GDL globals handle.

APIEnv_IsInCurtainWallEditModeID  Featuring API 12

Returns if applicaton is in curtain wall editing mode.

APIEnv_IsInStairEditModeID  Featuring API 21

Returns if applicaton is in stair editing mode.

APIEnv_IsInBeamEditModeID  Featuring API 23

Returns if applicaton is in beam editing mode.

APIEnv_IsInColumnEditModeID  Featuring API 23

Returns if applicaton is in column editing mode.

APIEnv_GetTWAccessRightID  Featuring API 14

Returns if the current user has the specifed access right.

APIEnv_GetGDLDateID  Featuring API 17

Returns GDL environment date information.

APIEnv_ChangeGDLDateID  Featuring API 17

Changes GDL environment date.

 

Requirements

Version: API 2.1 or later
Header: ACAPinc.h, APIdefs_Environment.h

 

See Also

General Functions, API Functions