Creates a new Favorites entry based on the given element.
GSErrCode ACAPI_Favorite_Create ( const API_Favorite& favorite );
Parameters
- favorite
- [in] The Favorite entry settings.
Return Values
NoError
- The function has completed with success.
APIERR_BADNAME
- Invalid name given.
APIERR_GENERAL
- The new Favorites list entry could not be created.
APIERR_BADPARS
- Invalid element given (invalid library part ID), or a marker was given with an element that is not an object.
APIERR_BADCLASSIFICATION
- One of the specified classification items is not available for the given element.
For other common API errors see the API Errors document.
Example
For detailed example, please see the Favorite_Test example Add-On.
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_Favorite_Create,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Export,
ACAPI_Favorite_Get,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_Import,
ACAPI_Favorite_Read,
API Functions