Creates a new Favorites entry based on the given element.
GSErrCode ACAPI_Favorite_Create ( API_Element* element, API_ElementMemo* memo, API_Element* elementMarker, API_ElementMemo* memoMarker, const GS::Array<API_Property>* properties, const GS::Array<GS::UniString>* folder, const GS::UniString* name );
Parameters
- element
- [in] The element, on which the new Favorites entry will be based on.
- memo
- [in] The memo of the above element.
- elementMarker
- [in] Marker of the above element, if it is an object.
- memoMarker
- [in] Memo of the above marker.
- properties
- [in] The properties to save in the Favorites entry.
- folder
- [in] The path of the target folder where the Favorite should be created (or nullptr, if it should be created in the root folder).
- name
- [in] The name of the new Favorites entry.
Return Values
NoError
- The function has completed with success.
APIERR_GENERAL
- The new Favorites list entry could not be created.
APIERR_BADPARS
- Invalid element given (null pointer or invalid library part ID), or a marker was given with an element that is not an object.
For other common API errors see the API Errors document.
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_Favorite_Create,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Export,
ACAPI_Favorite_GetDefaults,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_GetNumExt,
ACAPI_Favorite_Import,
ACAPI_Favorite_Read,
API Functions