Exports the Favorites in the plan into a Favorites file or folder.
GSErrCode ACAPI_Favorite_Export ( const IO::Location& location, const GS::Array<GS::UniString>* names = nullptr );
Parameters
- location
- [in] The path to the file (if the location has the Favorite binary’s extension) or folder (otherwise) to export to.
- names
- [in] The list of the Favorites to export.
Return Values
NoError
- The function has completed with success.
APIERR_NOACCESSRIGHT
- The location file or folder couldn’t be opened for write.
For other common API errors see the API Errors document.
Example
For detailed example, please see the Favorite_Test example Add-On.
Requirements
- Version: API 20 or later
- Header: ACAPinc.h
See Also
ACAPI_Favorite_Create,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Get,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_Import,
ACAPI_Favorite_Read,
API Functions