Loads the parameters of the given favorite.
GSErrCode ACAPI_Favorite_Get ( API_Favorite* favorite );
Parameters
- favorite
- [in/out] The Favorite entry settings. On input, it identifies the Favorite based on its name. On return, the other fields are filled.
Return Values
NoError
- The function has completed with success.
APIERR_GENERAL
- The Favorites list could not be retrieved.
APIERR_BADPARS
- The
favorite
parameter isnullptr
. APIERR_BADNAME
- Invalid name given (there is no Favorite with the given
favorite.name
).
For other common API errors see the API Errors document.
Remarks
This function does not create a new element into the database, you must use the ACAPI_Element_Create function to do so.
Example
For detailed example, please see the Favorite_Test example Add-On.
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_Favorite_GetPreviewImage,
ACAPI_Favorite_Create,
ACAPI_Favorite_Change,
ACAPI_Favorite_Rename,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Export,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_Import,
ACAPI_Favorite_Read,
API Functions