Loads element attributes based on the given Favorites entry.
GSErrCode ACAPI_Favorite_GetDefaults ( API_Element* element, API_ElementMemo* memo, API_Element* elementMarker, API_ElementMemo* memoMarker, GS::Array<API_Property>* properties, GS::Array<GS::Pair<API_Guid, API_Guid>>* classifications, GS::Array<API_ElemCategoryValue>* elemCategoryValues, GS::UniString* name );
Parameters
- element
- [in/out] The element to apply the settings on.
- memo
- [out] The memo of the element to apply the settings on.
- elementMarker
- [in/out] Optional reference to the marker to be modified, filled with the appropriate new parameters.
- memoMarker
- [out] Optional parameter for masking the relevant fields of elementMarker.
- properties
- [out] The properties stored in the Favorites entry.
- classifications
- [out] Classification system and item guid pairs of the Favorites entry.
- elemCategoryValues
- [out] Category values of the Favorites entry.
- name
- [in] Name of the Favorites entry to apply.
Return Values
NoError
- The function has completed with success.
APIERR_GENERAL
- The Favorites list could not be retrieved.
APIERR_BADPARS
- Element or name not given.
APIERR_BADNAME
- Invalid name given.
For other common API errors see the API Errors document.
Remarks
The newly created element will not be added to the database, you must use the ACAPI_Element_Create function to do so.
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_Favorite_Create,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Export,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_Import,
ACAPI_Favorite_Read,
API Functions