ACAPI_​Favorite_​GetNum

Returns the names and indexes of the contents of the Favorites list, along with the amount of entries, for a given type and variation.

    GSErrCode  ACAPI_Favorite_GetNum (
        const API_ElemType&                     type,
        short*                                  count,
        GS::Array<API_FavoriteFolderHierarchy>* folders,
        GS::Array<GS::UniString>*               names
    );

 

Parameters

type
[in] The given type of elements.
count
[out] The amount of entries for that type and variation combination in the Favorites list.
folders Changed in API 22
[out] The folders of the entries for that type and variation combination in the Favorites list.
names
[out] The names of the entries for that type and variation combination in the Favorites list.

 

Return Values

NoError
The function has completed with success.
APIERR_GENERAL
The Favorites list could not be retrieved.

For other common API errors see the API Errors document.

 

Remarks

The API_FavoriteFolderHierarchy type is a typedef of GS::Array<GS::UniString>.

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example

For detailed example, please see the Favorite_Test example Add-On.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_Favorite_Create,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Export,
ACAPI_Favorite_Get,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_Import,
ACAPI_Favorite_Read,

API Functions