ACAPI_​Favorite_​GetNum

Returns the names and indexes of the contents of the Favorites list, along with the amount of entries, for a given type and variation.

    GSErrCode  ACAPI_Favorite_GetNum (
        API_ElemTypeID                          typeID,
        API_ElemVariationID                     variationID,
        short*                                  count,
        GS::Array<short>*                       indexes,
        GS::Array<GS::Array<GS::UniString>>*    folders,
        GS::Array<GS::UniString>*               names
    );

 

Parameters

typeID
[in] The given type of elements.
variationID
[in] The given variation of the above element type.
count
[out] The amount of entries for that type and variation combination in the Favorites list.
indexes
[out] The indexes of the entries for that type and variation combination in the Favorites list.
folder API 20 feature
[out] The folders of the entries for that type and variation combination in the Favorites list..
names
[out] The names of the entries for that type and variation combination in the Favorites list.

 

Return Values

NoError
The function has completed with success.
APIERR_GENERAL
The Favorites list could not be retrieved.
APIERR_BADPARS
The count parameter or both indexes and names parameters were null pointers.

For other common API errors see the API Errors document.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_Favorite_Create,
ACAPI_Favorite_CreateExt,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Export,
ACAPI_Favorite_GetDefaults,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_Import,
ACAPI_Favorite_Read,

API Functions