Reads the contents of a Favorite file or folder and returns them without modifying the plan. ACAPI_Favorite_Read combined with ACAPI_Favorite_Create works much like ACAPI_Favorite_Import, however it gives more control, but it is less efficient.
GSErrCode ACAPI_Favorite_Read ( const IO::Location& location, GS::Array<API_Favorite> *favorites );
Parameters
- location
- [in] The path to the Favorite file or folder to read.
- favorites
- [out] The parameters of the imported Favorites.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The location isn’t a valid Favorite file or folder path.
For other common API errors see the API Errors document.
Example
For detailed example, please see the Favorite_Test example Add-On.
Requirements
- Version: API 20 or later
- Header: ACAPinc.h
See Also
ACAPI_Favorite_Create,
ACAPI_Favorite_Delete,
ACAPI_Favorite_Export,
ACAPI_Favorite_Get,
ACAPI_Favorite_GetNum,
ACAPI_Favorite_Import,
API Functions