ACAPI_​Goodies_​ElemTypeToNeigID

Returns a neig for the given element type.

    GSErrCode ACAPI_Goodies_ElemTypeToNeigID (
        const API_ElemType&   elemType,
        API_NeigID&           neigID
    );

 

Parameters

elemType
The element type.
neigID
One neig ID for that element type.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function return a neig ID (a special point) for the given element type. This is useful in some situations, for example element selection, where you have to pass the array of neig IDs of the elements you want to select, but it is not important, which point of the element is given.

Note that the element type ⇒ neig ID mapping is not a one-to-one, but a one-to-many mapping.

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

API_ElemType, API_NeigID,
API Functions