ACAPI_​Goodies_​GetElemTypeName

Returns the localized name of the built-in element types.

    GSErrCode ACAPI_Goodies_GetElemTypeName (
        const API_ElemType&  elemType,
        GS::UniString&       elemName
    );

 

Parameters

elemType
[in] The element type
elemName
[out] The name of the element type in the language of the Archicad version currently running

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Invalid element type value.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the name of the specified element type in the language the currently running program is localized for.

 

Example


API_ElemType elemType = API_AngleDimensionID;
GS::UniString elemName;
if (ACAPI_Goodies_GetElemTypeName (elemType, elemName) == NoError)
    DBPrintf ("Angle Dimension is called \"%s\"\n", (const char*) elemName.ToCStr ());

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

API_ElemType
API Functions