ACAPI_​Goodies_​NeigIDToElemType

Returns the element type assigned to a neig.

    GSErrCode ACAPI_Goodies_NeigIDToElemType (
        API_NeigID      neigID,
        API_ElemType&   elemType
    );

 

Parameters

neigID
[in] neig identifier
elemType
[out] element type identifier

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are nullptr
APIERR_BADID
Invalid neigID has been passed

For other common API errors see the API Errors document.

 

Remarks

This function is used to convert a neig identifier to element type.

Refer to the API_NeigID structure to get information how neigs are assigned to elements.

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

API_NeigID, API_ElemType,
API Functions