Augments the ifcDifference with previously deleted items and merges olderIfcRelationshipData with newerIfcRelationshipData.
GSErrCode ACAPI_IFC_ComplementIFCDifferenceAndMergeIFCRelationshipData ( const API_IFCRelationshipData& olderIfcRelationshipData, const API_IFCRelationshipData& newerIfcRelationshipData, API_IFCDifference& ifcDifference, API_IFCRelationshipData& mergedIfcRelationshipData );
Parameters
- olderIfcRelationshipData
- [in] An olderly modified API_IFCRelationshipData.
- newerIfcRelationshipData
- [in] A newerly modified API_IFCRelationshipData.
- ifcDifference
- [in/out] The difference between the above two API_IFCRelationshipData.
- mergedIfcRelationshipData
- [out] The merged result of the above two API_IFCRelationshipData.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- If any error occured executing the function.
For other common API errors see the API Errors document.
Remarks
Merges olderIfcRelationshipData with newerIfcRelationshipData and complete ifcDifference with the deleted elements.
Requirements
- Version: API 26 or later
- Header: APIdefs_IFC.h
See Also
ACAPI_IFC_GetIFCDifference,
ACAPI_IFC_GetIFCDifferenceState,
ACAPI_IFC_GetIFCRelationshipData