ACAPI_​IFC_​GetIFCDifference

Generates an IFC Difference based on the input parameters.

    GSErrCode ACAPI_IFC_GetIFCDifference (
        API_IFCDifferenceGeneratorState&     previousIFCDifferenceGeneratorState,
        API_IFCDifferenceGeneratorState&     currentIFCDifferenceGeneratorState,
        API_IFCDifference&                   ifcDifference
    );

 

Parameters

previousIFCDifferenceGeneratorState
[in] Previous IFCDifference Generator state.
currentIFCDifferenceGeneratorState
[in] Current IFCDifference Generator state.
ifcDifference
[out] The resulting IFC Difference.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
If any error occured during the conversion.

For other common API errors see the API Errors document.

 

Remarks

It generates an IFC Difference based on the input parameters.

 

Requirements

Version: API 26 or later
Header: APIdefs_IFC.h

 

See Also

ACAPI_IFC_GetIFCDifferenceState