ACAPI_​IFC_​GetIFCExportTranslatorsList

Returns the valid IFC Export Translators.

    GSErrCode ACAPI_IFC_GetIFCExportTranslatorsList (
        GS::ArrayAPI_IFCTranslatorIdentifier>&      ifcExportTranslators
    );

 

Parameters

ifcExportTranslators
[out] The resulting IFC Export Translators.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
If any error occured during the conversion.

For other common API errors see the API Errors document.

 

Remarks

Returns the valid IFC Export Translators. The first item of the ifcExportTranslators is the preview translator.

 

Requirements

Version: API 26 or later
Header: APIdefs_Automate.h