ACAPI_​IFC_​InvokeIFCDifferenceExportSettingsDlg

It opens a dialog where a View and an IFC Export Translator can be selected.

    GSErrCode ACAPI_IFC_InvokeIFCDifferenceExportSettingsDlg (
        API_Guid&  			 viewGuid,
        API_IFCTranslatorIdentifier&     ifcTranslatorIdentifier
    );

 

Parameters

viewGuid
[in/out] A view Guid. Returns the selected view guid.
ifcTranslatorIdentifier
[in/out] An IFC Export Translator. Returns the selected IFC Export Translator identifier.

 

Return Values

NoError
The function has completed with success.
Cancel
The user cancelled the export settings dialog.

For other common API errors see the API Errors document.

 

Remarks

A dialog where the user can select a View and an IFC Export Translator.

 

Requirements

Version: API 26 or later
Header: APIdefs_IFC.h