ACAPI_​Install_​AddOnObjectMergeHandler

Installs a callback procedure for handling the AddOnObject merge operations.

    GSErrCode  ACAPI_Install_AddOnObjectMergeHandler (
        APIAddonObjectMergeHandlerProc*     mergeHandlerProc
    );

 

Parameters

mergeHandlerProc
[in] The callback procedure which will handle the AddOnObject data merge. Can be nullptr; this removes the installed callback.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your add-on to pass the pointer of the APIAddOnObjectMergeHandlerProc callback routine implemented for resolving conflicts between two lists of the AddOnObjects of the add-on during a merge operation.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

APIAddOnObjectMergeHandlerProc
ACAPI_Register_AddOnObjectHandler
AddOnObject Manager
API Functions