ACAPI_​Install_​AddOnObjectSaveOld​FormatHandler

Installs a callback procedure for converting AddOnObject data into older format.

    GSErrCode  ACAPI_Install_AddOnObjectSaveOldFormatHandler (
        APIAddonObjectSaveOldFormatHandlerProc*     saveOldFormatProc
    );

 

Parameters

saveOldFormatProc
[in] The callback procedure to convert AddOnObject data. Passing nullptr in this parameter uninstalls the previously installed handler function.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your add-on to pass the pointer of the APIAddOnObjectSaveOldFormatHandlerProc callback routine implemented for converting modules of the add-on into previous format.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

APIAddOnObjectSaveOldFormatHandlerProc
ACAPI_Register_AddOnObjectHandler
AddOnObject Manager
API Functions