ACAPI_​Install_​ESYMHandler

Installs a callback for handling external symbols.

    GSErrCode  ACAPI_Install_ESYMHandler (
        GSType                  signature,
        APIESYMCommandProc*     handlerProc
    );

 

Parameters

signature
[in] A four-character identifier of the external symbol.
handlerProc
[in] The callback function to handle the creation and the editing of the external symbol.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your add-on.

 

Example


// -----------------------------------------------------------------------------
// Called when the add-on has been loaded into memory
// -----------------------------------------------------------------------------
GSErrCode __ACENV_CALL  Initialize (void)

{
    GSErrCode    err = NoError;

    err = ACAPI_Install_ESYMHandler ('ABCD', APIESYMCommandProc);

    return err;
}   // Initialize

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

API_ESYMParams, APIESYMCommandProc,
API Functions