ACAPI_​Install_​ModulDataMergeHandler

Installs a callback procedure for handling the module data merge operations.

    GSErrCode  ACAPI_Install_ModulDataMergeHandler (
        APIModulDataMergeHandlerProc*     mergeHandlerProc
    );

 

Parameters

mergeHandlerProc
[in] The callback procedure which will handle the module data merge. Can be nullptr; this removes the installed callback.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your add-on to pass the pointer of the APIModulDataMergeHandlerProc callback routine implemented for resolving conflicts between two instances of the same custom data section of the add-on during a merge operation.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

APIModulDataMergeHandlerProc
ACAPI_Register_ModulDataHandler
ModulData Manager
API Functions