ACAPI_​Install_​ModulDataSaveOld​FormatHandler

Installs a callback procedure for converting module data into older format.

    GSErrCode  ACAPI_Install_ModulDataSaveOldFormatHandler (
        APIModulDataSaveOldFormatHandlerProc*     modulDataSaveOldFormatProc
    );

 

Parameters

modulDataSaveOldFormatProc
[in] The callback procedure to convert module data. Passing nullptr in this parameter uninstalls the previously installed handler function.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your add-on to pass the pointer of the APIModulDataSaveOldFormatHandlerProc callback routine implemented for converting modules of the add-on into previous format.

 

Requirements

Version: API 13 or later
Header: ACAPinc.h

 

See Also

APIModulDataSaveOldFormatHandlerProc
ACAPI_Register_ModulDataHandler
ModulData Manager
API Functions