ACAPI_​Install_​NavigatorAddOnViewPointDataMergeHandler

Installs a callback procedure for handling the Navigator AddOn viewpoint merge operations.

    GSErrCode  ACAPI_Install_NavigatorAddOnViewPointDataMergeHandler (
        APINavigatorAddOnViewPointDataMergeHandlerProc*     mergeHandlerProc
    );

 

Parameters

mergeHandlerProc
[in] The callback procedure which will handle the Navigator AddOn viewpoint data merge. If nullptr is passed, an installed callback function is removed.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your AddOn.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

APINavigatorAddOnViewPointDataMergeHandlerProc
ACAPI_Register_NavigatorAddOnViewPointDataHandler
API Functions