ACAPI_​Install_​NavigatorAddOnViewPointDataSaveOld​FormatHandler

Installs a callback procedure for converting Navigator AddOn viewpoints into older format.

    GSErrCode  ACAPI_Install_NavigatorAddOnViewPointDataSaveOldFormatHandler (
        APINavigatorAddOnViewPointDataSaveOldFormatHandlerProc*     saveOldFormatProc
    );

 

Parameters

saveOldFormatProc
[in] The callback procedure which will handle the Navigator AddOn viewpoints’ conversion into older format. If nullptr is passed, an installed callback function is removed.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called in the Initialize function of your AddOn.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

APINavigatorAddOnViewPointDataSaveOldFormatHandlerProc
ACAPI_Register_NavigatorAddOnViewPointDataHandler
API Functions