ACAPI_​Install_​PropertyObjectHandler

Installs the property handler function for the given menu item.

    GSErrCode  ACAPI_Install_PropertyObjectHandler (
        short                             strResID,
        APIPropertyObjectCommandProc*     propertyCommandProc
    );

 

Parameters

strResID
[in] The string resource ID you install the property handler for.
propertyCommandProc
[in] The property command handler function.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

The string resource will appear in Archicad’s dialogs. This function should be called from the Initialize function of the add-on, after registering the property handler with ACAPI_Register_PropertyObjectHandler.

 

Example


//------------------------------------------------------
// Called after the add-on has been loaded into memory
//------------------------------------------------------
GSErrCode __ACENV_CALL  Initialize (void)
{
    ACAPI_Install_MenuHandler (MenuResId, Callback_Check_AVA_OR_DIN_MenuItem);
    ACAPI_Install_PropertyObjectHandler (PropertyResId, Callback_Property);

    return NoError;
}

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

APIPropertyObjectCommandProc, ACAPI_Register_PropertyObjectHandler
API Functions