ACAPI_​Install_​PublisherSaveOption

Installs the option methods for the Publisher

    GSErrCode  ACAPI_Install_PublisherSaveOption (
        const char*       mimeType,
        SaveOptionProc*   saveOptionProc,
    );

 

Parameters

mimeType
The unique mimeType which identifies the new publish format
saveOptionProc
Callback function, called in case of publishing

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function installs the callback functions for the new publish formats. The Add-on can create his own option dialog, the settings are stored in API_Userdata structures.

 

Example

Refer to the Format Register Test example project of the API Development Kit.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

SaveOptionProc
ACAPI_Register_PublishFormat
API Functions