ACAPI_​Install_​PublisherTranslatorGetter

Installs the translator getter function for the Publisher

    GSErrCode  ACAPI_Install_PublisherTranslatorGetter (
        const char*  mimeType,
        TranslatorGetterProc*    translatorGetterProc,
    );

 

Parameters

mimeType
The unique mimeType which identifies the new publish format
translatorGetterProc
Callback function, called from the Organizer

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function installs the callback functions for the new publish formats. The publisher will call the registered function, during the setup of the formats in the Organizer.

 

Example

Refer to the Format Register Test example project of the API Development Kit.

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

TranslatorGetterProc
ACAPI_Register_PublishFormat
API Functions