ACAPI_​Install_​SettingsHandler

Installs the create/destroy handlers for the registered settings observer.

    GSErrCode  ACAPI_Install_SettingsHandler (
        const API_ElemType&      tool,
        APISettingsCreateProc*   handlerCreateProc,
        APISettingsDestroyProc*  handlerDestroyProc
    );

 

Parameters

tool
[in] The element type that identifies the settings dialog
handlerCreateProc
[in] Callback function, called when the settings dialog is created.
handlerDestroyProc
[in] Callback function, called when the settings dialog is destroyed.

 

Return Values

APIERR_BADPARS
No settings observer was registered for the settings dialog specified by tool and variaton.
NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function installs the callback functions for handling create/destroy events of the settings dialog observer registered by ACAPI_Register_SettingsObserver.

The ACAPI_Install_SettingsHandler function should be called from Initialize.

The ‘create’ handler is called when the settings dialog is created. The ‘destroy’ handler is called when the settings dialog is destroyed.

New in API 26 From version 26 the tool and variation parameters were merged into a single API_ElemType parameter.

 

Example

Refer to the Panel_Test example project of the API Development Kit.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

APISettingsCreateProc
APISettingsDestroyProc
ACAPI_Register_SettingsObserver
API Functions