ACAPI_​Interface

Controls several user interface components.

    GSErrCode  ACAPI_Interface (
        API_InterfaceID     code,
        void*               par1 = nullptr,
        void*               par2 = nullptr,
        void*               par3 = nullptr,
        void*               par4 = nullptr,
        void*               par5 = nullptr
    );

 

Parameters

code
[in] Interface function identifier.
par1
[in/out] The parameter depends on the code parameter.
par2
[in/out] The parameter depends on the code parameter.
par3
[in/out] The parameter depends on the code parameter.
par4 API 16 feature
[in/out] The parameter depends on the code parameter.
par5 API 20 feature
[in/out] The parameter depends on the code parameter.

 

Return Values

NoError
The interface function completed with success.
APIERR_BADID
Invalid code parameter was passed.

More return values can be found at the description of each interface functions.

 

Remarks

This function collects all of the user interface control capability that can be used from an API tool add-on (except the DG functionality).

The type of the interface function is specified with the code parameter.

API_InterfaceID

Description

 

 

Menu items

 

APIIo_GetMenuItemFlagsID

Returns the flag values of a specified menu item.

APIIo_SetMenuItemFlagsID

Sets the flag values of a specified menu item.

APIIo_GetMenuItemTextID

Returns the text of a specified menu item.

APIIo_SetMenuItemTextID

Sets the text of a specified menu item.

APIIo_AddMenuItemTextID  15

Sets the text of a specified menu item that will appear in the Work Environment dialog.

 

 

Process Window

 

APIIo_InitProcessWindowID

Opens the process window.

APIIo_CloseProcessWindowID

Closes the process window.

APIIo_SetNextProcessPhaseID

Starts the next process phase in the process window.

APIIo_SetProcessValueID

Sets the value of the progress bar.

APIIo_IncProcessValueID

Increases the value of the progress bar.

APIIo_IsProcessCanceledID

Checks for user breaks during long processes.

APIIo_GetProcessOnOffSwitchID  17

Returns whether the process window will appear.

APIIo_SetProcessOnOffSwitchID  17

Turns the process window on/off.

 

 

User input

 

APIIo_InitNeigFilterID

Initializes the neig filter for an input.

APIIo_SetNeigFilterID

Sets one of the neig types to be filtered.

APIIo_ClearNeigFilterID

Sets one of the neig types not to be filtered.

APIIo_GetPointID

Performs a point input.

APIIo_GetLineID

Performs a line input.

APIIo_GetArcID

Performs an arc input.

APIIo_GetPolyID

Performs a polygon input.

APIIo_DrawRubberLineID

Draws graphical feedback during an input process.

APIIo_DrawRubberArcID

Draws graphical feedback during an input process.

APIIo_PetPaletteID

Opens a pet palette for the add-on.

APIIo_CompleteUserInputID

Finishes the user input.

APIIo_CancelUserInputID

Cancels the user input.

APIIo_SetUserControlCallbackID

Sets the default callback procedures for user controls.

APIIo_ObjectSettingsID

Brings up the Object/Lamp/Window/Door Settings dialog.

APIIo_SettingsDialogID

Opens any Settings dialog.

APIIo_SetConstraintID  6.1

Sets the drawing constraint for graphical user input.

APIIo_ResetConstraintID  6.1

Dissolves the drawing constraint.

 

 

File dialogs

 

APIIo_SaveLibPartFileDialogID  10

Opens a Library Part file saving dialog window.

 

 

Cutting Planes

 

APIIo_Is3DCutawayEnabledID  20

Returns whether the 3DCutaway is enabled.

APIIo_Set3DCutawayStatusID  20

Turns the 3DCutaway on/off.

APIIo_IsCuttingPlanesVisibleID  20

Returns whether the Cutting Planes are visible.

APIIo_SetCuttingPlanesVisibilityID  20

Shows or hides the Cutting Planes.

 

Requirements

Version: API 2.1 or later
Header: ACAPinc.h

See Also

General Functions, API Functions