Adds a new section to the Library Part under creation.
GSErrCode ACAPI_LibPart_AddSection ( const API_LibPartSection* section, GSHandle sectionHdl, GS::UniString* sectionStr );
Parameters
- section
- [in] Parameters of the new section.
- sectionHdl
- [in] Section data.
- sectionStr
- [in] Content of any textual section as a Unicode string.
Return Values
NoError
- The function has completed with success.
APIERR_GENERAL
- No scratch file has been opened by the ACAPI_LibPart_Create function.
For other common API errors see the API Errors.
Remarks
This function is used to add a whole section to the Library Part opened to create.
This function is allowed to call between the ACAPI_LibPart_Create and ACAPI_LibPart_Save functions only, while creating a Library Part from scratch. The identifier of the section must be defined in the API_LibPartSection parameter. The section data is passed through the sectionHdl
parameter.
Example
See the example of the ACAPI_LibPart_Create function.
Requirements
- Version: API 1.3 or later
- Header: ACAPinc.h
See Also
API_LibPartSection,
ACAPI_LibPart_Create, ACAPI_LibPart_Save,
LibPart Manager, API Functions