ACAPI_​LibPart_​Get

Returns the data of a registered Library Part.

    GSErrCode  ACAPI_LibPart_Get (
        API_LibPart*     libPart
    );

 

Parameters

libPart
[in/out] Definition of the library part.
The Library Part should be identified by the index field. Other fields are ignored, they are output parameters.

 

Return Values

NoError
The function has completed with success.
APIERR_MISSINGDEF
The originating library part file is missing. The document name is still filled.
APIERR_BADPARS
libPart is nullptr or the index is invalid.
APIERR_BADINDEX
libPart.index is not correct for the given typeID.

For other common API errors see the API Errors.

 

Remarks

This function is used to get the data of the requested Library Part defined by the index field. The other fields of the structure are returned by Archicad. You cannot use names here; first you have to find the library part with ACAPI_LibPart_Search function.

After calling ACAPI_LibPart_Get please remember to free the location pointer allocated by the function if you do not need it any more.

 

Example

See the example of the ACAPI_LibPart_GetNum function.  

 

Requirements

Version: API 1.3 or later
Header: ACAPinc.h

 

See Also

API_LibPart,
ACAPI_LibPart_GetNum, ACAPI_LibPart_Search,
LibPart Manager, API Functions