ACAPI_​LibPart_​GetSect_​2DDrawHdl

Returns the 2D binary (drawing) section data created from API elements.

    GSErrCode  ACAPI_LibPart_GetSect_2DDrawHdl (
        GSHandle*     sectionHdl
    );

 

Parameters

sectionHdl
[out] 2D binary section data

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
sectionHdl is nullptr
APIERR_GENERAL
No 2D drawing section has been opened with the ACAPI_LibPart_SetUpSect_2DDrawHdl function.

For other common API errors see the API Errors.

 

Remarks

This function is used to close and return the 2D binary (drawing) section of the library part, prepared to be used with ACAPI_LibPart_AddSection function.

This function must be called to close the 2D binary section if the ACAPI_LibPart_SetUpSect_2DDrawHdl function has succeeded; even if any of the in-between function calls to ACAPI_Element_Create has failed.

Refer to the ACAPI_LibPart_SetUpSect_2DDrawHdl function to get more details on this topics.

 

Example

See the example of the ACAPI_LibPart_Create function.

 

Requirements

Version: API 1.3 or later
Header: ACAPinc.h

 

See Also

ACAPI_LibPart_SetUpSect_2DDrawHdl, ACAPI_LibPart_AddSection, ACAPI_Element_Create,
LibPart Manager, API Functions