ACAPI_​LibPart_​NewSection

Opens a new section to write into the Library Part under creation.

    GSErrCode  ACAPI_LibPart_NewSection (
        const API_LibPartSection*     section
    );

 

Parameters

section
[in] Parameters of the new section.

 

Return Values

NoError
The function has completed with success.
APIERR_GENERAL
No scratch file has been opened by the ACAPI_LibPart_Create function.

For other common API errors see the API Errors.

 

Remarks

This function is used to open a new section to write into the Library Part opened to create.

This function is allowed to call between the ACAPI_LibPart_Create and ACAPI_LibPart_Save functions only, while creating a Library Part from scratch. The identifier of the section must be defined in the API_LibPartSection parameter. The section data is passed through the sectionHandle parameter.

This is the other way to add sections to the library part, where the section is opened, then data is added with repetitive calls to the ACAPI_LibPart_WriteSection function, and finally it is closed with the ACAPI_LibPart_EndSection function call.

Refer to the ACAPI_LibPart_AddSection to add a section in one step.

Do not nest these function calls. Always close the opened section with ACAPI_LibPart_EndSection before you open an other.

 

Example

See the example of the ACAPI_LibPart_Create function.

 

Requirements

Version: API 1.3 or later
Header: ACAPinc.h

 

See Also

API_LibPartSection,
ACAPI_LibPart_WriteSection, ACAPI_LibPart_EndSection, ACAPI_LibPart_Create, ACAPI_LibPart_AddSection, ACAPI_LibPart_Save,
LibPart Manager, API Functions