ACAPI_​LibPart_​RegisterAll

Registers an array of Library Parts.

    GSErrCode  ACAPI_LibPart_RegisterAll (
        GS::Array<API_LibPart>*     libParts
    );

 

Parameters

libParts
[in/out] Parameters of the library parts; the type, the owner signature and the location of the library parts must be initialized, by setting the typeID, ownerID and the location fields respectively. Other values will be filled and returned by Archicad.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
libParts is nullptr, or any of its members refer to invalid data.

For other common API errors see the API Errors.

 

Remarks

This function is used to register an array of new library parts. During the time of the batch registration internal library part caching is disabled, providing better performance.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example


GS::Array<API_LibPart> libParts;

for (int i = 0; i < 10; ++i) {
    API_LibPart      libPart;

    // ... fill API_LibPart structure

    libParts.Push (libPart);
}

err = ACAPI_LibPart_RegisterAll (&libParts);

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

API_LibPart,
ACAPI_LibPart_Register,
ACAPI_LibPart_Save,
LibPart Manager, API Functions