ACAPI_​LibPart_​Save

Saves the Library Part has been created and registers it.

    GSErrCode  ACAPI_LibPart_Save (
        API_LibPart*     libPart
    );

 

Parameters

libPart
[in/out] Parameters of the library part to create

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The libPart parameter is nullptr
APIERR_GENERAL
No scratch file has been opened with the ACAPI_LibPart_Create function.

For other common API errors see the API Errors.

 

Remarks

This function is used to save the recently created library part by the ACAPI_LibPart_Create function.

The same parameters should be passed in the API_LibPart structure as it was pass to the ACAPI_LibPart_Create function. In the index field, the library index of the currently created library part is returned, which you can use in subsequent operations.

This function must be called to close the scratch if the ACAPI_LibPart_Create function has succeed; even if any of the in-between function calls have failed.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example

See the example of the ACAPI_LibPart_Create function.  

 

Requirements

Version: API 1.3 or later
Header: ACAPinc.h

 

See Also

API_LibPart,
ACAPI_LibPart_Create, APIEnv_OverwriteLibPartID,
LibPart Manager, API Functions