ACAPI_​LibPart_​SetDetails_​ParamDef

Sets the detail parameters of a Library Part parameter section handle.

    GSErrCode  ACAPI_LibPart_SetDetails_ParamDef (
        const API_LibPart*            libPart,
        GSHandle                      paramHdl,
        const API_LibPartDetails*     details
    );

 

Parameters

libPart
[in] The library part to work on.
paramHdl
[in/out] Parameter section data
details
[in] Detail parameters

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are nullptr

For other common API errors see the API Errors.

 

Remarks

This function is used to store detail parameters in the parameter section handle. These parameters can be edited in Archicad by clicking the Details button on the parameter list editor dialog box.

Applicable type of Library Parts are:

To get the detail parameters of a registered Library Part refer to the ACAPI_LibPart_GetDetails function.

Note, that the ACAPI_LibPart_GetDetails and ACAPI_LibPart_SetDetails_ParamDef functions are not symmetrical; it is shown in the function names too. Since the detail parameters are stored in the parameter section of the Library Part, this implementation interface is the most effective.

 

Example

See the example of the ACAPI_LibPart_Create function.  

 

Requirements

Version: API 2.1 or later
Header: ACAPinc.h

 

See Also

API_LibTypeID
API_LibPartDetails
ACAPI_LibPart_GetDetails
LibPart Manager
API Functions