Sets up an empty 2D binary (drawing) section to fill up from API elements.
GSErrCode ACAPI_LibPart_SetUpSect_2DDrawHdl ( void );
Return Values
NoError
- The function has completed with success.
APIERR_NESTING
- recursive call, ACAPI_LibPart_GetSect_2DDrawHdl was not called after the previous call
APIERR_MEMFULL
- not enough memory
For other common API errors see the API Errors.
Remarks
This function is used to initialize the 2D binary (drawing) section of the library part.
The subsequent calls to the element creation function ACAPI_Element_Create will be redirected. Instead of putting the created elements into the current database it will put them into the opened 2D symbol drawing, until the ACAPI_LibPart_GetSect_2DDrawHdl function is called.
This is the only way to add a 2D binary drawing section to a Library Part. However the internal format of the section handle is public, it is a quite hard job to provide a full solution without this functionality.
Example
See the example of the ACAPI_LibPart_Create function.
Requirements
- Version: API 1.3 or later
- Header: ACAPinc.h
See Also
ACAPI_Element_Create, ACAPI_LibPart_GetSect_2DDrawHdl,
LibPart Manager, API Functions