ACAPI_​LibPart_​UpdateSection

Updates a section of a registered Library Part.

    GSErrCode  ACAPI_LibPart_UpdateSection (
        Int32                         libInd,
        const API_LibPartSection*     section,
        GSHandle                      sectionHdl,
        GS::UniString*                sectionStr,
        GS::UniString*                password = nullptr
    );

 

Parameters

libInd
[in] Index of the Library Part
section
[in] Identifier of the section.
sectionHdl
[in] Section data.
sectionStr Featuring API 11
[in] Optional Unicode content of any textual section.
password Featuring API 16
[in] The (optional) password that encrypted the section.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid libInd, or
any of the parameters are nullptr, or
the addressed Library Part is a macro, picture file etc.

For other common API errors see the API Errors.

 

Remarks

This function is used to update the requested section of the library part defined by libInd with the data in the supplied handle.

In the case the identified section exists in the Library Part it will be updated; if the section is not found it will be created.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 1.3 or later
Header: ACAPinc.h

 

See Also

API_LibPartSection,
LibPart Manager, API Functions