ACAPI_​LibPart_​WriteSection

Writes data into an opened section of the Library Part under creation.

    GSErrCode  ACAPI_LibPart_WriteSection (
        Int32          nByte,
        GSConstPtr     data
    );

 

Parameters

nByte
[in] Number of bytes.
data
[in] Data to be written.

 

Return Values

NoError
The function has completed with success.
APIERR_GENERAL
No section has been opened with the ACAPI_LibPart_NewSection function.

For other common API errors see the API Errors.

 

Remarks

This function is used to write data into the section recently opened with ACAPI_LibPart_NewSection function.

It writes the given data (nByte number of bytes addressed by data) to the section recently opened with ACAPI_LibPart_NewSection function. If you write the data to a textual section, don’t forget to include the newline (+linefeed for Windows) character(s) in data.

 

Example

See the example of the ACAPI_LibPart_Create function.

 

Requirements

Version: API 2.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_LibPart_NewSection, ACAPI_LibPart_EndSection, ACAPI_LibPart_Create,
LibPart Manager, API Functions