Retrieves the data of a listdata.
GSErrCode ACAPI_ListData_Get ( API_ListData* listdata );
Parameters
- listdata
- [in/out] Parameters of the listdata. The type of the listdata, the index of the set and the index of the listdata must be passed in the
typeID
, thesetIndex
and theindex
fields in the listdata header. Other fields of the structure are filled in automatically.
Return Values
NoError
- The function has completed with success.
APIERR_BADINDEX
- Invalid listdata index was passed.
APIERR_BADID
- Invalid listdata type was passed.
APIERR_DELETED
- Invalid listdata was deleted.
For other common API errors see the API Errors document.
Remarks
This function is used to get a listdata, defined by the typeID,
the setIndex
and the index
fields of the listdata header. The information of a given listdata is returned in the fields of the listdata.
This function is faster than ACAPI_ListData_GetLocal.
When getting the listdata, the applicable fields should be filled in.
API_ListData_Head
setIndex
required; must be >= 1
typeID
required
index
required
If you are retrieving a descriptor, don’t forget to dispose of the name handle when you’re finished.
Example
API_ListData listdata; GSErrCode err; BNZeroMemory (&listdata, sizeof (API_ListData)); listdata.header.setIndex = 1; listdata.header.typeID = API_DescriptorID; listdata.header.index = 1; err = ACAPI_ListData_Get (&listdata); BMKillHandle (&listdata.descriptor.name);
Requirements
- Version: API 2.1 or later
- Header: ACAPinc.h
See Also
API_ListData,
ACAPI_ListData_GetLocal,
Listing Manager, API Functions