ACAPI_​ListData_​GetSet

Retrieves the data of a listdata set.

    GSErrCode  ACAPI_ListData_GetSet (
        API_ListDataSetType*     listdataSet
    );

 

Parameters

listdataSet
[in/out] Parameters of the set. The index of the set must be passed in the setIndex field in the listdataSet; it must be greater than 0. The other fields of the structure are filled in automatically.

 

Return Values

NoError
The function has completed with success.
APIERR_BADINDEX
Invalid listdataSet setindex was passed.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get a listdata set, defined by the setIndex field of the listdataSet. The information of a given listdata set is returned in the fields of the listdataSet.

When getting the listdata set, the applicable fields should be filled.

API_ListDataSetType

setIndex

required

 

Example


API_ListDataSetType  listdataSet;
GSErrCode            err;

BNZeroMemory (&listdataSet, sizeof (API_ListDataSetType));
listdataSet.setIndex = 1;

err = ACAPI_ListData_GetSet (&listdataSet);

 

Requirements

Version: API 2.1 or later
Header: ACAPinc.h

 

See Also

API_ListData_GetSetType,
ACAPI_ListData_Get,
Listing Manager, API Functions