ACAPI_​MarkUp_​AddComment

Adds a new comment to the given Mark-Up.

    GSErrCode  ACAPI_MarkUp_AddComment (
        const API_Guid&            markUpGuid,
        API_MarkUpCommentType&     comment
    );

 

Parameters

markUpGuid
[in] GUID of the existing Mark-Up.
comment
[in/out] The parameters of the new comment. The guid and creaTime will be filled by this function.

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADPARS
The passed markUpGuid parameter was incorrect.

For other common API errors see the API Errors document.

 

Remarks

A new comment can be added to an existing Mark-Up entry using this function.
Use ACAPI_MarkUp_GetList function to return the list of all Mark-Up entries and ACAPI_MarkUp_GetComments function to get the previously added comments.

 

Example

Mark-Up related code samples can be found in the MarkUp_Manager example add-on.


API_MarkUpCommentType comment (/*author:*/ "API", /*text:*/ "ACAPI_MarkUp_AddComment", /*status:*/ APIComment_Warning);
GSErrCode err = ACAPI_MarkUp_AddComment (markUp.guid, comment);

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

API_MarkUpCommentType, API_MarkUpType
ACAPI_MarkUp_GetComments, ACAPI_MarkUp_Create, ACAPI_MarkUp_GetList
API Functions