ACAPI_​MarkUp_​AttachElements

Attach elements to an existing Mark-Up as corrected or highlighted elements.

    GSErrCode  ACAPI_MarkUp_AttachElements (
        const API_Guid&                    markUpGuid,
        const GS::Array<API_Guid>&         elemList,
        API_MarkUpComponentTypeID          type,
        GS::HashTable<API_Guid, API_Guid>* modificationElemTable = nullptr
    );

 

Parameters

markUpGuid
[in] GUID of the existing Mark-Up.
elemList
[in] The list of elements to attach.
type  API 26 feature
[in] Attach the elements with the given Component type.
modificationElemTable  API 26 feature
[in/out] Optional parameter, used only when APIMarkUpComponent_Modification is passed in type parameter. The table of the original and the modified element pairs.
If the given table does not contain the element as key, then a new element will be created as the modified pair. But if the table already contains the element, then the pair in the table will be set as the modified element.

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADPARS
The passed markUpGuid parameter or at least one of the given element GUIDs was incorrect.

For other common API errors see the API Errors document.

 

Remarks

Using this function an existing element can be attached to an existing Mark-Up entry.
Note that an element can be attached to only one Mark-Up as creation or deletion, but it can be attached to more Mark-Ups as highlighted and cannot be attached as highlighted and creation/deletion simultaneously. If the requested attachment would violate these rules than APIERR_BADPARS error code will be returned.
Use ACAPI_MarkUp_GetAttachedElements function to return the already attached elements of the Mark-Up entry and ACAPI_MarkUp_DetachElements function to detach previously added elements.

 

Example

Mark-Up related code samples can be found in the MarkUp_Manager example add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

API_MarkUpType, API_MarkUpComponentTypeID
ACAPI_MarkUp_GetList, ACAPI_MarkUp_GetAttachedElements, ACAPI_MarkUp_DetachElements
API Functions