ACAPI_​MarkUp_​Change

Changes an existing Mark-Up entry.

    GSErrCode  ACAPI_MarkUp_Change (
        API_MarkUpType&                   markUp,
        const bool                        placeTagText,
        const API_Coord*                  tagTextCoord = nullptr
    );

 

Parameters

markUp
[in/out] The modified parameters of the Mark-Up.
placeTagText
[in] Place tag text element for the Mark-Up.
tagTextCoord
[in] Coordinates of the placed tag text. (optional when tagTextCoord parameter’s value is false)

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADPARS
The passed markUp.guid parameter was incorrect or the given tagTextCoord is nullptr however tagTextCoord is true.

For other common API errors see the API Errors document.

 

Remarks

Use this function to change the paramters of an existing Mark-Up entry.
If the Mark-Up hasn’t got placed tag text element, then this function can place one automatically using placeTagText parameter. Using tagTextCoord the coordinates of the attached tag text can be given.
Use ACAPI_MarkUp_Create function to create and ACAPI_MarkUp_Delete function to delete Mark-Up entry.
Elements can be attached to the Mark-Up using ACAPI_MarkUp_AttachElements and comment can be added with ACAPI_MarkUp_AddComment function.

 

Example

Mark-Up related code samples can be found in the MarkUp_Manager example add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

API_MarkUpType
ACAPI_MarkUp_GetList, ACAPI_MarkUp_Create, ACAPI_MarkUp_Delete
API Functions