ACAPI_​MarkUp_​Create

Creates new Mark-Up entry.

    GSErrCode  ACAPI_MarkUp_Create (
        API_MarkUpType&     markUp
    );

 

Parameters

markUp
[in/out] The parameters of the new Mark-Up. The GUID and time stamp typed fields will be filled by this function.

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.

For other common API errors see the API Errors document.

 

Remarks

Using this function a new Mark-Up entry can be created.
Use ACAPI_MarkUp_Change function to change and ACAPI_MarkUp_Delete function to delete an existing Mark-Up entry.
Elements can be attached to the Mark-Up using ACAPI_MarkUp_AttachElements and comment can be added with ACAPI_MarkUp_AddComment function.

 

Example


bool hasRight = false;
ACAPI_Environment (APIEnv_GetTWAccessRightID, (void*) APIMarkupEntryCreate, &hasRight);
if (!hasRight)
    return APIERR_NOACCESSRIGHT;

API_MarkUpType markUp (/*name:*/ "- Test MarkUp -");
markUp.tagText = "MarkUp API";

GSErrCode err = ACAPI_MarkUp_Create (markUp);

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

API_MarkUpType
ACAPI_MarkUp_GetList, ACAPI_MarkUp_Change, ACAPI_MarkUp_Delete
API Functions