ACAPI_​MarkUp_​Delete

Deletes an existing Issue.

    GSErrCode  ACAPI_MarkUp_Delete (
        const API_Guid&                   markUpGuid,
        bool                              acceptAllElements = false
    );

 

Parameters

markUpGuid
[in] GUID of an existing Issue.
acceptAllElementsFeaturing API 26
[in] Accept all entry suggestions before the delete operation.

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
There is no opened project.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADID
Issue not found with the given guid.
APIERR_NOACCESSRIGHT
The current user doesn’t have the right to delete the Issue in the teamwork project.
APIERR_BADPARS
Failed to accept all entry suggestions.

For other common API errors see the API Errors document.

 

Remarks

Use this function to delete an existing Issue.
If the Issue has any attached suggestion element, then depending on the value of the acceptAllElements parameter, the suggestion elements will be deleted or kept after the deletion of the owner Issue.
Use ACAPI_MarkUp_Create function to create and ACAPI_MarkUp_Delete function to delete an Issue.
Use ACAPI_MarkUp_GetAttachedElements function to return the attached elements of the Issue.

 

Example

Issue related code samples can be found in the MarkUp_Manager example add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

API_MarkUpType
ACAPI_MarkUp_GetList, ACAPI_MarkUp_Create, ACAPI_MarkUp_Change
API Functions