ACAPI_​MarkUp_​DetachElements

Detach elements from an existing Mark-Up.

    GSErrCode  ACAPI_MarkUp_DetachElements (
        const API_Guid&                markUpGuid,
        const GS::Array<API_Guid>&     elemList
    );

 

Parameters

markUpGuid
[in] GUID of the existing Mark-Up.
elemList
[in] The list of elements to detach.

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADPARS
The passed markUpGuid parameter or at least one of the given element GUIDs was incorrect.

For other common API errors see the API Errors document.

 

Remarks

Using this function (corrected or highlighted) elements can be detached from an existing Mark-Up entry.
Use ACAPI_MarkUp_GetAttachedElements function to return the already attached elements of the Mark-Up entry and ACAPI_MarkUp_AttachElements function to attach elements.

 

Example

Mark-Up related code samples can be found in the MarkUp_Manager example add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

API_MarkUpType
ACAPI_MarkUp_GetList, ACAPI_MarkUp_GetAttachedElements, ACAPI_MarkUp_AttachElements
API Functions