ACAPI_​MarkUp_​ExportToBCF

Exports a BCF file to specified location.

    GSErrCode  ACAPI_MarkUp_ExportToBCF (
    const IO::Location&			fileLoc,
    const GS::Array<API_Guid>& 		markupEntryIds,
    const bool				useExternalId = false
    const bool				alignBySurveyPoint = true
    );

 

Parameters

fileLoc
[in] The location of the BCF file.
markupEntryIds
[in] An Array containing the MarkUp Entry identifiers to export.
useExternalId
[in] Use external IFC ID or Archicad IFC ID as referenced in BCF topics.
alignBySurveyPoint
[in] Align BCF views by Archicad Survey Point or Archicad Project Origin. Featuring API 26

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Use this function to export BCF files.

For deatails about External IFC ID and Archicad IFC ID see: ACAPI_Element_GetIFCIdentifier.

 

Example


		
GSErrCode DoBCFExport ()
{
	GS::Array markUps;
	GS::Array markupEntryIds;

	GSErrCode err = ACAPI_MarkUp_GetList (APINULLGuid, &markUps);

	for (const auto& markUp : markUps)
		markupEntryIds.Push (markUp.guid);

	if (err == NoError) {
		DG::FileDialog exporteDLG (DG::FileDialog::Type::OpenFile);
		if (exporteDLG.Invoke ())
			err = ACAPI_MarkUp_ExportToBCF (exporteDLG.GetSelectedFile (), markupEntryIds, false, true);
	}

	if (err != NoError)
		ErrorBeep ("ACAPI_MarkUp_ExportToBCF failed", err);

	return err;
}
For detailed examples, please see the MarkUp_Manager add-on.

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

API Functions