Returns the corrected and highlighted elements of the given Mark-Up.
GSErrCode ACAPI_MarkUp_GetAttachedElements ( const API_Guid& markUpGuid, API_MarkUpComponentTypeID type, GS::Array<API_Guid>* attachedElements );
Parameters
- markUpGuid
- [in] GUID of the existing Mark-Up.
- type
- [in] Return the attached elements with the given Component type.
- attachedElements
- [out] The list of the attachedElements elements of the Mark-Up.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed
markUpGuid
parameter was incorrect.
For other common API errors see the API Errors document.
Remarks
Using this function the corrected and highlighted elements of an existing Mark-Up entry can be listed.
ACAPI_MarkUp_GetList returns the list of the existing Mark-Ups.
Use ACAPI_MarkUp_AttachElements function to attach and ACAPI_MarkUp_AttachElements function to detach elements.
Example
Mark-Up related code samples can be found in the MarkUp_Manager example add-on.
Requirements
- Version: API 21 or later
- Header: ACAPinc.h
See Also
API_MarkUpType
ACAPI_MarkUp_GetList, ACAPI_MarkUp_AttachElements, ACAPI_MarkUp_DetachElements
API Functions