Returns the existing Mark-Up entries which the given element is attached to.
GSErrCode ACAPI_MarkUp_GetList ( const API_Guid& elemGuid, GS::Array<API_MarkUpType>* markUpList, bool* asCorrected = nullptr );
Parameters
- elemGuid
- [in] The GUID of the element or
APINULLGuid
to list all Mark-Ups. - markUpList
- [out] The list of Mark-Up(s).
- asCorrected
- [out] Returns whether the given element is a corrected or highlighted element in the listed Mark-Up(s).
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed
elemGuid
parameter was invalid or the passedmarkUpList
isnullptr
.
For other common API errors see the API Errors document.
Remarks
Use this function to list which Mark-Ups is the given element attached to. To list all the existing Mark-Ups pass APINULLGuid
to the elemGuid
parameter.
Use ACAPI_MarkUp_Create function to create and ACAPI_MarkUp_Delete function to delete Mark-Up entries.
Note that an element can be attached to only one Mark-Up as corrected, but it can be attached to more Mark-Ups as highlighted and cannot be corrected and highlighted simultaneously. So if true
was returned in asCorrected
output parameter, then the size of the retuned markUpList
array must be 1.
Example
Mark-Up related code samples can be found in the MarkUp_Manager example add-on.
GS::Array<API_MarkUpType> markUpList; GSErrCode err = ACAPI_MarkUp_GetList (APINULLGuid, &markUpList);
Requirements
- Version: API 21 or later
- Header: ACAPinc.h
See Also
API_MarkUpType
ACAPI_MarkUp_Create, ACAPI_MarkUp_Delete
API Functions